Installing Gimp 2.5.2 on Ubuntu

In an earlier post I mentioned a guide to build Gimp 2.5.0 on Ubuntu Hardy Heron. Back then the guide failed on my machine.

With the recent release on Gimp 2.5.2 I decided to give it another try and this time it worked. Below I have listed the specific commands. A few dependencies might be missing.

I case you don’t have the build tools installed (or have no idea if you do):

sudo apt-get install build-essential
sudo apt-get build-dep gimp

Also, to make the commands below work you need to have wget installed:

sudo apt-get install wget

In case you don’t have a /opt directory:

sudo mkdir /opt

In case you have a previous installation, remove this (or move it out of the way):

sudo mv /opt/gimp-2.5 /opt/gimp-2.5.backup

Run the following commands:

export PATH=/opt/gimp-2.5/bin:$PATH
export LD_LIBRARY_PATH=/opt/gimp-2.5/lib
export PKG_CONFIG_PATH=/opt/gimp-2.5/lib/pkgconfig

cd /tmp

svn co http://svn.gnome.org/svn/babl/trunk/ babl
cd babl
./autogen.sh –prefix=/opt/gimp-2.5
make
sudo make install
cd ..

svn co http://svn.gnome.org/svn/gegl/trunk/ gegl
cd gegl
./autogen.sh –prefix=/opt/gimp-2.5
make
sudo make install
cd ..

wget ftp://ftp.gimp.org/pub/gimp/v2.5/gimp-2.5.2.tar.bz2
tar jxvf gimp-2.5.2.tar.bz2
cd gimp-2.5.2
./configure –prefix=/opt/gimp-2.5
make
sudo make install

If everything went well you should be able to start it by running:

/opt/gimp-2.5/bin/gimp-2.5

Advertisements

Tags: ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: